28 Jul 2009 @ 10:46 AM 

chrysler-sebring-convertableI don’t know why it wasn’t running in the first place.  Like I said in an earlier post when I would try to start it a 20 amp fuse would pop.  So, frustrated, I let my car sit there collecting dirt to the point it was beginning to look like a natural rock formation.  Well, sheer embarrassment drove me (forgive the pun) to take another look at it.  If for any reason than to move it so I can wash it.  I bought some new fuses and tried one and the silly thing started.  I pulled it into the driveway figuring I got lucky and the next time I tried to start it that poor fuse would be sacrificed to the demons possessing my car.  Well, the silly thing started again!  Once again, I don’t know what’s wrong with it.  Maybe it’s just temperamental or just a brat.  Anyway, I have a small warehouse of fuses in the glove compartment just in case and since it’s been running again the fuse has only gone out once.  Go figure…

Posted By: David
Last Edit: 27 Jul 2009 @ 09:46 AM

EmailPermalink
Tags
Tags: ,
Categories: Big Dave's Log


 

Responses to this post » (None)

 
Post a Comment

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>


 Last 50 Posts
Change Theme...
  • Users » 3
  • Posts/Pages » 84
  • Comments » 4
Change Theme...
  • VoidVoid
  • LifeLife
  • EarthEarth
  • WindWind « Default
  • WaterWater
  • FireFire
  • LightLight